Archive for the ‘Eclipse’ Category

Eclipse Ganymede: Mylyn Task und Mantis Version 1.2.0a

Monday, July 14th, 2008

Und noch ein Problem mit Eclipse Ganymede. Diesmal mit dem von mir so geliebten Mylyn Plugin und dem Mylyn Mantis Connector.
Bei dem Hinzufügen eines neues Mylyn Mantis Repositories verlangt der Mantis Connector einen Mantis Server “1.1.0 or greater”. Ich habe die aktuelle Developer Version Mantis 1.2.0a installiert. Das sollte also grösser sein als 1.1.0. Es wird aber eine Fehlermeldung angezeigt, die angibt dass als Version nur 1.1.0 oder einige Versionen darunter verwendet werden können.

Mein Hack, der aber bislang problemlos funktioniert ist der, in Mantis selbst den Versionsstring zu ändern. Dieser befindet sich in der Datei

core/constant_inc.php

und dort gleich in der ersten Zeile

define( ‘MANTIS_VERSION’, ‘1.2.0a1’ );

diese muss man ändern in

define( ‘MANTIS_VERSION’, ‘1.1.0’ );

Dann funktioniert der Mylyn Mantis Connector wie gewohnt.
Natürlich wird in Mantis selbst am Ende jeder Zeile auch diese falsche Versionsnummer angezeigt.
Das ist aber wesentlich einfacher als die Java Sourcen des Mantis Connectors zu ändern, die ich mir bislang noch gar nicht angesehen habe. Sicherlich wird in den nächsten Tagen aber auch eine angepasste Version dieses Connectors erscheinen.

Eclipse Ganymede: Keine SVN Connectoren vorhanden

Monday, July 14th, 2008

Ich stolpere gerade darüber, dass in dem aktuellen Eclipse Ganymede zwar endlich eine direkte SVN Unterstützung eingebunden ist, wenn man aber unter Team-SVN Connector den entsprechenden Connector auswählen will – dann ist dieser leer. Wenn man trotzdem einen SVN Zugriff versucht, erhält man die folgende Fehlermeldung:

“Selected SVN connector library is not available or cannot be loaded.”

Das stimmt, denn es ist ja keine eingetragen. Man muss unter Help-Update Sites erst die folgende externe Adresse eintragen:

http://www.polarion.org/projects/subversive/download/eclipse/2.0/update-site/
Und diese Pakete installieren. Dann funktioniert alles so wie man es sich vorgestellt hat.

Warum das nicht automatisch mitinstalliert wird ist mir wirklich ein Rätsel.